Forward - Payment Elements were not loading – Incident details
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
Dark mode
All systems operational
Payment Elements were not loading
Resolved
Major outage
Started 3 months ago
May 08, 2026
Lasted 35 minutes
May 08, 2026
1:00
1:35 PM
UTC
Affected
Partner API
Major outage from 1:00 PM to 1:35 PM
Updates
Resolved
May 08, 2026 at 1:35 PM
UTC
Resolved
May 08, 2026 at 1:35 PM
UTC
This incident has been resolved.
Identified
May 08, 2026 at 1:00 PM
UTC
Identified
May 08, 2026 at 1:00 PM
UTC
Issue identified and we are working on a fix.
UTC
UTC
UTC
UTC
UTC